Fun with MAC Addresses and Crossbeam X80s

August 22nd, 2013

We had a fun little gotcha a few weeks ago while upgrading a Crossbeam X80 CPM from XOS 9.5.X to 9.6.6. As part of security controls we have in place in the perimeter, we implement MAC address filtering on the border switches. We implement very basic ACLs for the MAC addresses.

mac access-list extended mac_gi26
 permit host 0003.d2e0.0101 any
interface GigabitEthernet0/26
 switchport access vlan 901
 switchport mode access
 mac access-group mac_gi26 in
 spanning-tree portfast

So,  post upgrade to XOS 9.6.6 we lost access to many of our zones that previously worked.  After some digging around, we noted that the MAC addresses on the Crossbeam NPMs changed post upgrade.  This change was not noted in the Release Notes (at least I couldn’t find it).

The good news is that Crossbeam allows for the manual changing of MAC addresses on the X-Series Platform.  A simple change of the MAC address cleaned everything up.

[no] mac-addr <MAC_address>

IPSEC S2S VPN via AWS Openswan and Cisco IPSEC Router

February 20th, 2013

I was asked to assist on setting up a Site-to-Site (S2S) VPN between an Amazon Web Service AC2 environment and a Cisco IPSEC router.  Instead of working on the customer’s production environment, I decided to setup my Cisco 2821 router as an IPSEC endpoint and try to do it from home.  There is a fair amount of instructions on the internet on how to do this.  But, it seems no matter what I tried, I wasn’t able to get it to work.  The biggest hurdle was the fact that my Cisco IPSEC router was behind a NATing firewall.  Please note, the IP addresses have been changed on my example to some randoms.

I relied heavily on this post titled CONNECTING TO A CISCO ASA VPN VIA AMAZON EC2/VPC to get the basis on how to do this.  It took me about two days to get everything the way I wanted it, so I’m going to tackle the instructions on my own as well.

Here is a quick and dirty diagram:

IPSEC-EC2

Start a Amazon VPC Instance

  1. Go to the VPC tab.
  2. I chose a Ubuntu 64 Bit AMD64 server, micro instance.
  3. Click Network & Security –> Elastic IPs
  4. Allocate New Address, associate the new address to the new micro instance.
  5. I didn’t setup the Amazon firewall initially.
  6. Test SSH into your instance, you should get a UNIX prompt.

Before you begin installing and configuring your Cisco device or Openswan, you need to gather some information:

EC2 Side

Private IP: 10.96.42.55
Elastic IP: 54.235.135.80

Home Side

Private Network: 1.1.1.0/24
Router Public IP: 192.168.1.5
Firewall Public IP: 71.162.211.111

Install and Configure Openswan

  • From the command prompt, run sudo apt-get install openswan openswan-doc ipsec-tools
  • Edit /etc/sysctl.conf:

net.ipv4.ip_forward = 1

  • Run sudo ipsec verify (note any issues)
  • Edit /etc/ipsec.conf

nat_traversal=yes

protostack=netkey

include /etc/ipsec.d/*.conf

  • Run sudo ipsec verify (all issues should be resolved or have N/A,WARNING)
  • Run sudo service ipsec restart

 

Edit /etc/ipsec.d/home.conf (new file)

conn home

left=%defaultroute
leftsubnet=10.96.42.55/32
leftid=54.235.135.80
right=71.162.211.111
rightid=192.168.1.5
rightsubnet=1.1.1.0/24
authby=secret
ike=3des-md5
esp=3des-md5
keyexchange=ike
auto=start

Edit /etc/ipsec.d/home.secrets (new file)

192.168.1.5 54.235.135.80 : PSK “cisco123”

 

Configure the Cisco Router

crypto isakmp policy 10
 encr 3des
 hash md5
 authentication pre-share
 group 5
 lifetime 3600
crypto isakmp key cisco123 address 54.235.135.80
crypto ipsec security-association lifetime seconds 28800
crypto ipsec transform-set AMAZON-TRANSFORM-SET esp-3des esp-md5-hmac
crypto map INTERNET-CRYPTO 11 ipsec-isakmp
 description Amazon EC2 instance
 set peer 54.235.135.80
 set transform-set AMAZON-TRANSFORM-SET
 match address 111
interface GigabitEthernet0/0
 ip address 192.168.1.5 255.255.255.0
 no ip route-cache cef
 no ip route-cache
 duplex auto
 speed auto
 crypto map INTERNET-CRYPTO
interface GigabitEthernet0/1
 ip address 1.1.1.1 255.255.255.0
 duplex auto
 speed auto
ip route 0.0.0.0 0.0.0.0 192.168.1.1
access-list 111 permit ip 1.1.1.0 0.0.0.255 host 10.96.42.55

 

Important Notes:

  • I setup my home router/firewall to create the 192.168.1.5 IP address as a DMZ.  This means that I didn’t need to setup any type of port forwarding or firewall rules, it was forwarding all traffic from my external IP address to the internal IP address.  Your mileage may vary.
  • Note the “right” and “rightid” calls in the home.conf file.  right=external IP at home, rightid=actual Cisco router IP. This is important.  Because I was behind a NATing firewall, these settings came into play.  IPSEC doesn’t play very well in NAT and even though I was using NAT-traversal, those settings were key.
  • This was just a simple IP to network test.  You’ll need to modify the ACLs as appropriate to access your devices.
  • I had a devil of a time matching the isakmp policies and transform-set settings on the Cisco with the Openswan.  Both platforms use different terms for the same thing.  Some commands to know and love:
    • Openswan — sudo ipsec auto –status
    • Openswan — sudo ipsec whack –status
    • Ubuntu Logs — /var/log/auth.log
    • Cisco — debug crypto isakmp
    • Cisco — debug crypto ipsec
    • Cisco — debug crypto isakmp error
    • Cisco — debug crypto ipsec error

 

 

Product Review — Logitech Harmony Touch

October 19th, 2012

I’m a big fan of the Logitech Harmony product line.  Before purchasing the Touch, I already own the Harmony One Advanced Remote and the Harmony 620 Advanced Remote.

My Harmony 620 has been struggling lately.  The LCD screen completely died and the button have not been as responsive as they used to be.  So, I jumped on the Logitech web site to see what they had to offer.

The Harmony Touch was released on October 1, 2013 — just 10 days before my search.  But, at $250, it was a pricey clicker to say the least.  I thought about getting the Harmony One remote but at $200, it wasn’t much of a downgrade in price.  So, off to Newegg I went and bought a new Touch.

When the box arrived, it’s a behemoth.  You can see the packaging stealsa lot of queues from Apple’s.  The boxes are thick and sturdy. The directions are quick and to the point and the device is presented in a very simple plastic cradle.

I plugged the charging base into the wall (yay!  no more batteries) and let the remote charge overnight.  The next evening, I went to MyHarmony.com, installed the necessary software and plugged the remote into my laptop.

As a prior owner of Harmony remotes, I knew what to expect.  This was my first time using MyHarmony.com.  My previous two remotes used the thick Harmony software that installed on my laptop.  Both the MyHarmony site and the Harmony software are pretty straightforward   My biggest complaint with the software is that you could not use multiple remotes under a single login.  So, since I had two remotes, I had to remember two logins.  With the MyHarmony this limitation is removed.

Setting up my devices in MyHarmony is really easy.  You enter in the brand name and the model number of every device in use.  After the site knows all the devices that are in use, you setup all the Activities.  I have a fairly limited number of devices but they do some fairly complicated things.

Here is my hardware:

  • TV
  • Receiver
  • Cable Box
  • Remote Camera Receiver (we have a camera installed in my sons room so we can watch him)

Here are my activities:

  • Watch TV (TV, Receiver, Cable Box)
  • Listen to Music (TV, Receiver)
  • Watch my Son (TV, Receiver, Remote Camera)

MyHarmony goes through a very brief question and answer session for each activity and programs the remote for the activities   The Watching Music and Watching my Son activities presented some minor problems for the software as the settings to bring these actions to live are not default standard   But, since I have some known experience with my other two Harmony remotes, I was quickly able to customize my remote to do exactly what I want and programmed it without issues.

I’ve now been using the remote for about a week and there are things about it that I like and things that I don’t.

Things I like:

  • Size/Weight/Materials
    • My favorite part of my Harmony remotes is the design.  They have a dog-bone shape to them where your hands fits perfectly inside the thin part of the remote.  Your thumbs, for the most part, can reach all the import buttons with ease.  The Harmony Touch is similarly shaped to my previous remotes, with one big improvement.  It has a slightly grip material where your hand sits that really feels nice.
  • Touch Screen
    • The touch screen with the icons is very similar your SmartPhone screen.  It’s fast, responsive and very slick.  The Favorite icons you can setup make it very easy to jump from channel to channel.  This has shown to be a great benefit to my 3 year old son.  He knows what the channel icon is for Disney Junior and he just clicks and it’s on.  No numbers, no guide.
  • DVR Button
    • Finally, a DVR button.  Both other remotes did not have this and I was always too lazy to program one.  So, I ended up just clicking menu, and finding the DVR selection under there.

Things I don’t like:

  • Touch Screen Location
    • Yes, I said I liked the touch screen and I do.  The problem is the location.  It’s smack in the middle of the remote.  So, the common buttons like channels, volume, DVR, menu, Guide are at the buttom of the remote near your thumb. This is a great spot.  Right above these common buttons is the touch screen.  Above the touch screen and at the top of the remote is the Play/Pause/FF/RR buttons used for DVRs/DVDs.  So, everytime I want to skip commercials, pause the TV or play, I need to slide my hand to the top of the remote.  This was not the case with my other remotes and for me this is my biggest complaint.
  • Price
    • $250?  Are you shitting me?  I’m glad I have a nice wife.
  • No number pad
    • This isn’t 100% accurate.  There is a number pad, but it’s built into the touch screen.  So, it takes a click or two to bring it up.  I understand the need to consolidate and improve, but I miss my number pad.
  • No keyboard
    • My Vizio TV has lots of neat-o applets that run things like Twitter and Pandora.  They require input for the username and password only once and then they are saved.  Most of the time.  Every once in a while, my SmartTV decides to be dumb and forget everything I taught it.  I then need to input all my logins again, via it’s onscreen keyboard.  I usually end up digging out the Vizio remote which has a very slick slider keyboard built in.

Overall, it’s a nice remote.   It’s very snazzy, has a cool touch screen and the MyHarmony site is probably easy and workable for most situations.  Is it worth the price?  Nah, that’s a serious premium for a remote control.  Most folks that want a easy to use, functional remote would be perfectly happy with the $50-$100 device that Logitech makes.

Goodnight Kodak…

February 19th, 2012

It has been widely reported that Kodak is going to exit the camera, camcorder and digital frame business.  I’ve long ago moved to my Nikon DSLR and have not used a Kodak brand camera for a number of year.  I didn’t think much of Kodak’s demise because it was just another example of a thriving company unable to adapt to the changing world of technology.  (See also RIM, Newspapers and the recording industry)

It wasn’t until I was brushing my teeth the other day that I was reminding of that quality product Kodak made, especially in the digital world.  I was once the proud owner of a Kodak DC290 digital camera.  This thing was a hulk and at 2.1 megapixels, my camera phone has a higher resolution.  But, that didn’t stop it from taking some damn good pictures.  It is a shame such a grand company is going down in flames in such a spectacular way.  I was never much of a film photographer.  I owned my share of the cameras, but my skills could never justify the cost of developing and I quickly lost interest.  With digital, the devices were able to make my mediocre shots looks great and throwing away the hundreds of junk shots for the nice ones was cheap and easy.  The Kodak DC290 did an excellent job of this.

Why was I reminded of this while brushing my teeth?  Because two of my favorite pictures ever taken, shown below, were taken with the DC290.  They currently hang in my bathroom and I get to look at them everyday.  I took then while on a trip to San Francisco, driving north on the Pacific Coast Highway.  I stopped to stretch my legs on the side of the road and this is the beauty that awaited me.

It is likely that Kodak will become a bankrupt patent holding company, suing other companies that were able to survive and prosper in this digital age, into oblivion.  I’ll still browse through my old shots taken with my DC290 and remember with fondness the pictures it took.

Cisco Router to Checkpoint FW-1 — IPSEC VPN Headaches with Supernetting

February 1st, 2012

I setup quite a few IPSEC site-to-site VPNs.  Hundreds maybe.  Most go fine.  10 minutes on the line, bing, bam boom, we have a working IPSEC tunnel.

My company uses Cisco router/ASRs for our termination points for IPSEC VPNs.  We also have Checkpoint firewalls doing the filtering.  Why the separation?  Because we love a good headache.

My biggest headache comes from when a third party is using a Checkpoint firewall as the VPN termination point and I am using my Cisco router.  Checkpoint firewalls, often by default, will super-net the encryption domain.  So, I might be using a /32 host ACL on my Cisco, the Checkpoint is sending a /24 or larger ACL.  This does not play well in Cisco land and Phase 2 usually fails.

The hard part with this is figuring out this is happening, because it’s not obvious.  What I have found is turning on a single debug command makes all the difference in the world.

debug crypto ipsec

This shows all kinds of nasty IPSEC messages when a tunnel is negotiating.  You try finding the error on a box that has 75 tunnels terminating on it.  It is not easy! But, as the debug messages are scrolling by, one little entry can give you all the help you need:

Feb 1 17:20:39: Crypto mapdb : proxy_match
src addr : 142.184.211.75
dst addr : 121.98.112.0/25
protocol : 0
src port : 0
dst port : 0

On this particular tunnel (IPs changed to protect the innocent) the third party was supposed to be NATing behind a /32 address on the 121.98.112.0 network.  But, his Checkpoint box was super-netting behind the /25 network.  Bad Checkpoint.

I was able to pick it up from that debug message and let him know to change his config.  Five minutes later, IPSEC tunnel was up, Phase 1 and Phase 2 setup and communication was clean.